A WordPress-centric search engine for devs and theme authors



customize_validate_{$this->id} ›

Since4.6.0
Deprecatedn/a
apply_filters( "customize_validate_{$this->id}", $validity, $value, $this )
Parameters: (3)
  • (WP_Error) $validity Filtered from `true` to `WP_Error` when invalid.
    Required: Yes
  • (mixed) $value Value of the setting.
    Required: Yes
  • (WP_Customize_Setting) $this WP_Customize_Setting instance.
    Required: Yes
Defined at:
Codex:

Validates a Customize setting value.

Plugins should amend the $validity object via its WP_Error::add() method.

The dynamic portion of the hook name, $this->ID, refers to the setting ID.





Source

$validity = apply_filters( "customize_validate_{$this->id}", $validity, $value, $this );