A WordPress-centric search engine for devs and theme authors



is_lighttpd_before_150 ›

Since2.5.0
Deprecatedn/a
is_lighttpd_before_150 ( No parameters )
Returns:
  • (bool) Whether the server is running lighttpd < 1.5.0.
Defined at:
Codex:

Is the server running earlier than 1.5.0 version of lighttpd?



Related Functions: is_allowed_http_origin

Source

function is_lighttpd_before_150() {
	$server_parts    = explode( '/', isset( $_SERVER['SERVER_SOFTWARE'] ) ? $_SERVER['SERVER_SOFTWARE'] : '' );
	$server_parts[1] = isset( $server_parts[1] ) ? $server_parts[1] : '';
	return  'lighttpd' == $server_parts[0] && -1 == version_compare( $server_parts[1], '1.5.0' );
}