A WordPress-centric search engine for devs and theme authors



dashboard_php_nag_class ›

Since5.0.0
Deprecatedn/a
dashboard_php_nag_class ( $classes )
Parameters:
  • (array) $classes Metabox classes.
    Required: Yes
Returns:
  • (array) Modified metabox classes.
Defined at:
Codex:

Adds an additional class to the PHP nag if the current version is insecure.



Source

function dashboard_php_nag_class( $classes ) {
	$response = wp_check_php_version();

	if ( $response && isset( $response['is_secure'] ) && ! $response['is_secure'] ) {
		$classes[] = 'php-insecure';
	}

	return $classes;
}